电话:13489884026
全部商品分类
快捷导航
展开

小喇叭     

全站
18天前
全站
2019-04-05
全站
2019-03-24
全站
天茗站长 说: 关于商品代发上传宣传,每个单子价格为2元,联系方式:QQ:53773979
2019-02-07
全站
2019-01-30

华为网络设备配置,实现私网数据在公网上传输,GREVPN技术实现 ...

[复制链接]
查看: 1853|回复: 0
我的人缘0

未注册企业

12

主题

26

帖子

74

积分

正式会员

Rank: 2Rank: 2

积分
74
最近学些了VPN的相关知识,现将学习成果汇报以下哈。分章节讲解GRE VPN,PPTP VPN,L2TP VPN,MPLS VPN,SSL VPN,如有需求请关注。废话少说,开始正文。
1 VPN概述
VPN(Virtural Private Network)虚拟局域网,实现在公网上传输私网数据。避免租用昂贵的专线线路。
当然还可以实现别的一些功能,比如翻墙了等等,这篇是技术交流文章,不讲述翻墙软件实现。
1.1 VPN概念
VPN,中文名称虚拟局域网,利用共享的公共网络设施对广域网设施进行仿真而构建的私有专用网络。在公共网络上组件的VPN就像企业现有的私网一样提供安全性、可靠性和可管理性。
图 VPN

1.2 核心技术
VPN的核心技术是隧道技术。
假如公网运行的协议A,私网运行的是协议B,PCA和PCB属于私网运行协议B,协议B的数据是不能直接在协议A的网络上传输的。这就需要隧道技术,PCA和PCB的通信需要通过隧道技术跨越协议A网络进行。在这个例子里,协议B称为载荷协议,协议A属于承载协议。如下图所示
图 VPN的主要概念

1.3 VPN的分类
VPN主要分为二层VPN、三层VPN和高层VPN。

  • 二层VPN :PPTP,L2TP
  • 二层三层之间VPN:MPLS VPN
  • 三层VPN:IPSec ,GRE VPN
  • 高层VPN:SSL VPN
2 GRE概述
2.1 概述
GRE(Generic Routing Encapsulation通用路由封装),实现了在任意一种协议中封装任意一种协议而设计的封装方法。
GRE用于这样一种场景,一个设备希望跨越一个协议A的网络发送B协议包到对端。A称为承载协议,B称为载荷协议。


图 GRE的协议栈

2.2 GRE的头部
GRE的头部最重要的字段是Protocol Type。如果该值为0800表示载荷协议是IP。如下图所示,该图只标识了重要字段。
图 GRE头部

2.3GRE实现IP over IP
IP over IP是指企业分部之间通过公共IP网络传送内部IP网的数据,从而实现网络层的site-to-site。如下图所示,IPv4同时为载荷协议和承载协议的GRE封装,即IP over IP,IP协议用协议号47标识GRE头,GRE头的Protocol Type的值为0x0800说明载荷协议是IP协议。
图 IP over IP的GRE封装

2.4 GRE隧道
GRE隧道引入了Tunnel接口的逻辑接口。隧道两端的路由器分别通过物理接口连接公共网络,并建立Tunnel接口构成一条虚拟链路。物理接口配置载荷协议的IP和相关配置,Tunnel接口配置承载协议的IP和相关配置。如下图所示。
图 IP over IP GRE隧道

3 GRE VPN配置
根据上述理论知识,下面进行相关的配置。网络拓扑图如下图所示。拓扑图中有两台PC,模拟不同地点的私网用户,两台路由器,模拟公网传输数据。相关的IP设置,连接关系如图所示。站点A采用10.1.1.0/24的私网地址,站点B采用10.1.3.0/24的私网地址。PC1的IP是10.1.1.10/24,PC2的IP地址是10.1.3.10/24。
网络拓扑图

初始状态,PC1是没办法ping通PC2的,如下图所示


配置步骤

  • step1:配置公网物理接口的ip地址
  • step2:配置tunnel0逻辑接口的IP地址,原物理接口地址,目的物理接口地址,keepalive
  • step3:配置私网之间的路由
相关配置
R1的配置
#
interface Ethernet0/0/0
ip address 10.1.1.1 255.255.255.0
#
interface Serial0/0/0
link-protocol ppp
ip address 192.13.2.1 255.255.255.0
#
interface Tunnel0/0/0
ip address 10.1.2.1 255.255.255.0
tunnel-protocol gre
keepalive
source 192.13.2.1
destination 192.13.2.2
#
ip route-static 10.1.3.0 255.255.255.0 Tunnel0/0/0
R2的配置
interface Ethernet0/0/0
ip address 10.1.3.1 255.255.255.0
#
interface Serial0/0/0
link-protocol ppp
ip address 192.13.2.2 255.255.255.0
#
interface Tunnel0/0/0
ip address 10.1.2.2 255.255.255.0
tunnel-protocol gre
keepalive
source 192.13.2.2
destination 192.13.2.1
#
ip route-static 10.1.1.0 255.255.255.0 Tunnel0/0/0
#
配置后PC1 ping PC2的结果如下图所示


总结,本文简要的讲解了VPN、GRE VPN的相关理论知识,并且在华为模拟器eNSP实现了GRE VPN的配置。
后续将讲解PPTP,L2TP,MPLS VPN,SSL VPN,有需求的请关注。
如有问题请在评论区留言讨论,若需更多帮助,请私信关注。谢谢

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
温馨提示:
1、在论坛里发表的文章仅代表作者本人的观点,与本网站立场无关。
2、论坛的所有内容都不保证其准确性,有效性,时间性。阅读本站内容因误导等因素而造成的损失本站不承担连带责任。
3、当政府机关依照法定程序要求披露信息时,论坛均得免责。
4、若因线路及非本站所能控制范围的故障导致暂停服务期间造成的一切不便与损失,论坛不负任何责任。
5、注册会员通过任何手段和方法针对论坛进行破坏,我们有权对其行为作出处理。并保留进一步追究其责任的权利。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

热销排行/品牌特卖SALE
  • 1

让创业更简单

  • 反馈建议:88292363@qq.com
  • 工作时间:周一到周五 9:00-21:00
13489884026

关注我们

Copyright   ©2014-2019  天茗网络科技有限公司  Powered by©天茗商城  技术支持:天茗网络   知道创宇云安全   ( 闽ICP备18026028号